summaryrefslogtreecommitdiff
path: root/dev-ml/opam/opam-2.0.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-ml/opam/opam-2.0.8-r2.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-ml/opam/opam-2.0.8-r2.ebuild')
-rw-r--r--dev-ml/opam/opam-2.0.8-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/opam/opam-2.0.8-r2.ebuild b/dev-ml/opam/opam-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..b94e4ef3bcb6
--- /dev/null
+++ b/dev-ml/opam/opam-2.0.8-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/extlib:=
+ ~dev-ml/opam-client-${PV}:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+src_prepare() {
+ default
+
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}