summaryrefslogtreecommitdiff
path: root/dev-ml/opam-file-format
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/opam-file-format
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/opam-file-format')
-rw-r--r--dev-ml/opam-file-format/Manifest3
-rw-r--r--dev-ml/opam-file-format/metadata.xml11
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/Manifest b/dev-ml/opam-file-format/Manifest
new file mode 100644
index 000000000000..340a14482158
--- /dev/null
+++ b/dev-ml/opam-file-format/Manifest
@@ -0,0 +1,3 @@
+DIST opam-file-format-2.1.0.tar.gz 23233 BLAKE2B 34d832c5ee13a0db43e77f3b33e7728faa7dccccc8daed50dca89630ab11d6f307413b8fecfef5a7c3e0f7ea04ef27105c8f42d8b5227d2587bdc2c2defe59d3 SHA512 b948545497de0386457a9b5772924572249e38164aa49d5ab2ac9442d1231a56a3b8132a95197d74cbbe34336a7edc04eaca351a8763c4a009a512085ca0ab25
+EBUILD opam-file-format-2.1.0.ebuild 728 BLAKE2B 6750f5f33d722c8d2ca34fedac9317b01e3cf146f6bd517ff86b88b8ae857a65a894622a9c035372f67c2b601cdf91e0caba901234da5ce633987c79eff9840f SHA512 2d5e16e1b431be60174d0ef49ddc78f3696503c24b90a934fd60ebfc021f0fc56bbf73c13f096e40d46694d1e3befce3581f4a1745c526a06c82199ebc3eace2
+MISC metadata.xml 331 BLAKE2B 751c0b5766797be20f0bed7ef34e0e09ecc3c374e57e872f861662cb2cc950797d977c96edb5666390ed4acad198b92cab8eb1f3990daebd30fc47a121942a6e SHA512 1947996742f0cf50068b4bd36a75605ba80bd268b3b89c4a34686832212fa5eaf1c74430f7a1ff8ef577e7a69363f8bb2313f9a8c69ab631465e12f9b58900a6
diff --git a/dev-ml/opam-file-format/metadata.xml b/dev-ml/opam-file-format/metadata.xml
new file mode 100644
index 000000000000..bd15aa2f0672
--- /dev/null
+++ b/dev-ml/opam-file-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam-file-format</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
new file mode 100644
index 000000000000..54b598e0e0a4
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}