summaryrefslogtreecommitdiff
path: root/dev-ml/ojquery
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ojquery
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ojquery')
-rw-r--r--dev-ml/ojquery/Manifest4
-rw-r--r--dev-ml/ojquery/metadata.xml11
-rw-r--r--dev-ml/ojquery/ojquery-0.1.ebuild32
-rw-r--r--dev-ml/ojquery/ojquery-9999.ebuild32
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ml/ojquery/Manifest b/dev-ml/ojquery/Manifest
new file mode 100644
index 000000000000..2a999aa86ba1
--- /dev/null
+++ b/dev-ml/ojquery/Manifest
@@ -0,0 +1,4 @@
+DIST ojquery-0.1.tar.gz 64335 BLAKE2B f6fc0377326a2eb4487f2e28ae8ed28be6518ea79b1a096cd90e1847d732878775105a3597ea13fde6b352611a39bd49f55792dd5b1f57a576eff80aa127c58e SHA512 57b0f7458fc44294df0993a1593f0f42d532834b7f6676e8093eb3c12d4c88a6084a99f831751fece69477d17ab84a0ebedd9873f5255aa8ee2a6d39996634d2
+EBUILD ojquery-0.1.ebuild 633 BLAKE2B 4f46e06760ace62543c24ddb5a5078ab6662b4ac14387f7fcc73715021fa6cfdcf70f5c74fe68f527415b116116b21a21a2be19adf79997778e8bfb56b1ba458 SHA512 7d8d6048fc50d8ea1efed0c946ee7aaace7e7a32086e07ee890c89c047ed50c8496f6c03101ccfaf21d0c6a52791541fbb3d42d906b10010612041c6a9116e51
+EBUILD ojquery-9999.ebuild 633 BLAKE2B 4f46e06760ace62543c24ddb5a5078ab6662b4ac14387f7fcc73715021fa6cfdcf70f5c74fe68f527415b116116b21a21a2be19adf79997778e8bfb56b1ba458 SHA512 7d8d6048fc50d8ea1efed0c946ee7aaace7e7a32086e07ee890c89c047ed50c8496f6c03101ccfaf21d0c6a52791541fbb3d42d906b10010612041c6a9116e51
+MISC metadata.xml 327 BLAKE2B 48844452f2846ad73155fd65930f3b1bfe5294587d20b4d8a1d02707897c0d0d1958a42c7d5937f74d3dee52bc3ca4004ea67737cd71fc7cde76cfda87d463b1 SHA512 b558a03fc62629ca3ad1516489aa16c659c90c91c6f908819a1368725e79a40e01b034a6eb77e9d3c4c25a2e654324bd8498612e9e0a981279ad74fc20373c56
diff --git a/dev-ml/ojquery/metadata.xml b/dev-ml/ojquery/metadata.xml
new file mode 100644
index 000000000000..5349bc49c096
--- /dev/null
+++ b/dev-ml/ojquery/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocsigen/ojquery</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ojquery/ojquery-0.1.ebuild b/dev-ml/ojquery/ojquery-0.1.ebuild
new file mode 100644
index 000000000000..a14024cc5d57
--- /dev/null
+++ b/dev-ml/ojquery/ojquery-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="jQuery Binding for Eliom."
+HOMEPAGE="https://github.com/ocsigen/ojquery"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ojquery"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ml/react:=
+ dev-ml/js_of_ocaml:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND} dev-ml/oasis"
+
+src_prepare() {
+ oasis setup || die
+}
diff --git a/dev-ml/ojquery/ojquery-9999.ebuild b/dev-ml/ojquery/ojquery-9999.ebuild
new file mode 100644
index 000000000000..a14024cc5d57
--- /dev/null
+++ b/dev-ml/ojquery/ojquery-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="jQuery Binding for Eliom."
+HOMEPAGE="https://github.com/ocsigen/ojquery"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ojquery"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ml/react:=
+ dev-ml/js_of_ocaml:=
+ dev-ml/lwt:="
+DEPEND="${RDEPEND} dev-ml/oasis"
+
+src_prepare() {
+ oasis setup || die
+}