summaryrefslogtreecommitdiff
path: root/dev-ml/odns/odns-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/odns/odns-0.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/odns/odns-0.3-r1.ebuild')
-rw-r--r--dev-ml/odns/odns-0.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/odns/odns-0.3-r1.ebuild b/dev-ml/odns/odns-0.3-r1.ebuild
new file mode 100644
index 000000000000..d330c21321f0
--- /dev/null
+++ b/dev-ml/odns/odns-0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml library to query DNS servers"
+HOMEPAGE="http://odns.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It is ancient and upstream is dead. Consider using ocaml-dns instead.
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt]
+ !dev-ml/dns
+ !dev-ml/ocaml-dns
+"
+DEPEND="${RDEPEND}"
+
+CLIBS="" # Workaround for bug #422683
+
+src_prepare() {
+ sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
+ epatch "${FILESDIR}/${P}-parmake.patch"
+}
+
+src_compile() {
+ emake -j1 #453434
+}
+
+src_install() {
+ findlib_src_preinst
+ PREFIX="${D}/usr" emake install
+ dodoc AUTHORS README
+}