summaryrefslogtreecommitdiff
path: root/dev-ml/ocurl/ocurl-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ocurl/ocurl-0.9.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ocurl/ocurl-0.9.1.ebuild')
-rw-r--r--dev-ml/ocurl/ocurl-0.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ocurl-0.9.1.ebuild b/dev-ml/ocurl/ocurl-0.9.1.ebuild
new file mode 100644
index 000000000000..d21999abf2a9
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
+LICENSE="MIT"
+SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples +ocamlopt"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ dev-ml/camlp4:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+src_compile() {
+ emake -j1 all
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.txt README.md
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}