summaryrefslogtreecommitdiff
path: root/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocsigen-start/ocsigen-start-9999.ebuild')
-rw-r--r--dev-ml/ocsigen-start/ocsigen-start-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild b/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
new file mode 100644
index 000000000000..0bc813010ad6
--- /dev/null
+++ b/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Eliom Base Application with users, (pre)registration, notifications, etc."
+HOMEPAGE="https://github.com/ocsigen/ocsigen-start"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-start"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-start/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=
+ dev-ml/pgocaml:=
+ dev-ml/macaque:=
+ dev-ml/ocaml-safepass:=
+ >=dev-ml/eliom-6.2:=
+ dev-ml/ocsigen-toolkit:=
+ dev-ml/ppx_deriving:=
+ dev-ml/yojson:=
+ dev-ml/OCaml-ImageMagick:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ DESTDIR="${ED}" OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ dodoc README.md
+}