summaryrefslogtreecommitdiff
path: root/dev-ml/ocplib-simplex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-ml/ocplib-simplex
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-ml/ocplib-simplex')
-rw-r--r--dev-ml/ocplib-simplex/Manifest2
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
index 7e0f06573773..94755b928741 100644
--- a/dev-ml/ocplib-simplex/Manifest
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -1,3 +1,5 @@
DIST ocplib-simplex-0.3.tar.gz 31013 BLAKE2B 30d1541f15bf9d2c55f51ed565f2feb63c2b0fbe0095c15849a22df0876ad992a3e6c15924dbbe5a798ab278c7e171e30cda815b1de2ec9bc19fc92bbe79ad95 SHA512 43373deb6e921a31526c27d33808c3520b4f375caf9e5237179db0e8d84b5be3bf43e061e2d991fc6de694958c64c7ede0b258400fb921c4139664e367958630
+DIST ocplib-simplex-0.4.tar.gz 31784 BLAKE2B 89ebb43ba59debc658b1400b24379dcb717f44f484742a4ea2227e1692f2d1d359469add4e3c22bd15b7a5044e4d45877994b40e80f28ec8639989bf28565d9a SHA512 5eb80f0c8ad32291d24423255c0359e139cd85e2262b0cbbfaffcab66d9a7eb66c9bf04bb9d5d5c103574ec7041a72cde5412e6cb03fc9fe4a8fd257dab49a76
EBUILD ocplib-simplex-0.3.ebuild 755 BLAKE2B b3c1b4fb214ea1c3a4deb79508ebcd58eb75b753899dc63edae5b38bbedeadb9baf26a8ecd2f57e44e267e3973248fe9bfe538fdcdb55e351156c6ab9bc9954e SHA512 665c3ca7adeeb547c390742ffe3127f6783a90262b7719b119d6aa962b58d9210c4b63c3c9341fd92d7083cb472b4aab748510a45015c18faa429ce4b084d3e9
+EBUILD ocplib-simplex-0.4.ebuild 755 BLAKE2B f2dd7fb038c8784f8a3490e14e740a31771fb72446ccd8082da85aef3ec63f64af2018d1a0415dea85e7f414413e258a0f74cb0a00897a7337874acdffb3c948 SHA512 8d5ffc9f7571446d50031b917c9b53f89fca7d7c40f04da55cd9853d9a67ba2582e3135abe08b3dd6070b174e770363c5d095e1bdd892998b19cf75d74d9e56f
MISC metadata.xml 410 BLAKE2B 517ce557434537aa6fcaf30b4d9ff7aab1c817bd3bdb9f4d2a7f7a8556e3911db55a79d6cadebe86ba018577ad9a1434b3073ed8811513a72c1522069f8bed41 SHA512 caf6a675ff8f7950d06b2ed55e0d8a1eed290fe4f14a68fc87e9c60b6b394cc029787692be7041b7d7e727d6187249ba61a324315742c1af50556496da23eb0f
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild
new file mode 100644
index 000000000000..eb9269280d79
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i -e "s:configure.in:configure.ac:g" \
+ Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"/usr/"$(get_libdir)"/ocaml
+}