summaryrefslogtreecommitdiff
path: root/dev-ml/ocplib-simplex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-13 21:03:07 +0100
commit8fbd420dce8836e6503b162092e07b6a77a89f1d (patch)
tree071c621ef44d7c1b24a430ac7671d68963b5a4cf /dev-ml/ocplib-simplex
parent12d78242dec4f785d0a0bfb1c00eee2d8996c53b (diff)
gentoo resync : 13.10.2017
Diffstat (limited to 'dev-ml/ocplib-simplex')
-rw-r--r--dev-ml/ocplib-simplex/Manifest3
-rw-r--r--dev-ml/ocplib-simplex/metadata.xml12
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
new file mode 100644
index 000000000000..5e1b8d685956
--- /dev/null
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -0,0 +1,3 @@
+DIST ocplib-simplex-0.3.tar.gz 31013 SHA256 59bf450593e2407d52029140803e0e1343d6e30d1564f65cb2b7ec9582681171 SHA512 43373deb6e921a31526c27d33808c3520b4f375caf9e5237179db0e8d84b5be3bf43e061e2d991fc6de694958c64c7ede0b258400fb921c4139664e367958630 WHIRLPOOL eb27382e3726bbdb408b41512bb7ff294a5cb6a06335c726ae2c7a197f6fe5c829cdd2f3b2cf6a0bea483e21025fea6146f571aad60c2f91f004dadec770b264
+EBUILD ocplib-simplex-0.3.ebuild 697 SHA256 18778ccb51252421f5defc5a79ffde7e0bbbee29b175c9e91af3ca9cad658ddf SHA512 6282acb1de3d8a8df7cf442a22ca2fdb082bc371f5b472f8872bc7b623ce249d3eb910a00cde05ebf5549a19fc6316e4493b6041a8074b2b1932a965fa1a9438 WHIRLPOOL 6860237eb2d7c96f4b1d97617c51561195e565802da1f2ac6a1769cf634e6840b89f0174a81967155611d0bf210d133e6e07b67be81c7959549a1c46f396e030
+MISC metadata.xml 410 SHA256 cc7ebc317723a3a1c71fef55e3716f75fac700544557ed96db65492c294fc67a SHA512 caf6a675ff8f7950d06b2ed55e0d8a1eed290fe4f14a68fc87e9c60b6b394cc029787692be7041b7d7e727d6187249ba61a324315742c1af50556496da23eb0f WHIRLPOOL 25b32d6cef11492cfd245e11fec343f4c8cd13dc37d5e7079c0c266cd5ee0fddaa7390470e30a4078d2d0003d2abc81cce2a3a4195f7b34d672ee513736eff45
diff --git a/dev-ml/ocplib-simplex/metadata.xml b/dev-ml/ocplib-simplex/metadata.xml
new file mode 100644
index 000000000000..01c5e44dd808
--- /dev/null
+++ b/dev-ml/ocplib-simplex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library implementing a simplex algorithm, in a functional style,
+ for solving systems of linear inequalities
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
new file mode 100644
index 000000000000..cf06261cf33b
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"usr/"$(get_libdir)"/ocaml
+}