summaryrefslogtreecommitdiff
path: root/dev-ml/ocplib-simplex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocplib-simplex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocplib-simplex')
-rw-r--r--dev-ml/ocplib-simplex/Manifest3
-rw-r--r--dev-ml/ocplib-simplex/metadata.xml12
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
new file mode 100644
index 000000000000..23c6e1dfcb2b
--- /dev/null
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -0,0 +1,3 @@
+DIST ocplib-simplex-0.3.tar.gz 31013 BLAKE2B 30d1541f15bf9d2c55f51ed565f2feb63c2b0fbe0095c15849a22df0876ad992a3e6c15924dbbe5a798ab278c7e171e30cda815b1de2ec9bc19fc92bbe79ad95 SHA512 43373deb6e921a31526c27d33808c3520b4f375caf9e5237179db0e8d84b5be3bf43e061e2d991fc6de694958c64c7ede0b258400fb921c4139664e367958630
+EBUILD ocplib-simplex-0.3.ebuild 756 BLAKE2B aad367b92f081f0d4f505449d76d7a26c4415ac8aa96c674396b48153234b6df2485ca18b2375a91a93c738119b29fa48a99106f7345304b2177d99cf710604b SHA512 0e9ff9bda6b8efe7b9e61510170ee65b60fdcc531dabd2ef125c0ce7c3d845a14a82ae74438b61641af7258a4d7665cbc34d7b2f4e12fee3bdf6e3101e84e000
+MISC metadata.xml 410 BLAKE2B 517ce557434537aa6fcaf30b4d9ff7aab1c817bd3bdb9f4d2a7f7a8556e3911db55a79d6cadebe86ba018577ad9a1434b3073ed8811513a72c1522069f8bed41 SHA512 caf6a675ff8f7950d06b2ed55e0d8a1eed290fe4f14a68fc87e9c60b6b394cc029787692be7041b7d7e727d6187249ba61a324315742c1af50556496da23eb0f
diff --git a/dev-ml/ocplib-simplex/metadata.xml b/dev-ml/ocplib-simplex/metadata.xml
new file mode 100644
index 000000000000..01c5e44dd808
--- /dev/null
+++ b/dev-ml/ocplib-simplex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library implementing a simplex algorithm, in a functional style,
+ for solving systems of linear inequalities
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
new file mode 100644
index 000000000000..af7162c862f4
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i -e "s:configure.in:configure.ac:g" \
+ Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"usr/"$(get_libdir)"/ocaml
+}