summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild b/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..6001ee9fb27f
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="https://github.com/backtracking/${PN}/releases/download/${PV}/${P}.tbz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/graphics:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune build --only-packages ocamlgraph @install || die
+}