summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
deleted file mode 100644
index 71e564d353db..000000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-1.8.8.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib
-
-DESCRIPTION="O'Caml Graph library"
-HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
-SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? ( dev-tex/hevea dev-ml/ocamlweb )"
-IUSE="doc examples gtk +ocamlopt"
-
-src_compile() {
- emake byte
- use ocamlopt && emake opt
-
- if use doc; then
- emake doc
- fi
-
- if use gtk; then
- emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
- fi
-}
-
-src_install() {
- findlib_src_preinst
- use ocamlopt || export WANT_OCAMLOPT=no
- use gtk && export WANT_GTK=yes
- emake install-findlib
-
- if use gtk ; then
- local ext=byte
- use ocamlopt && ext=opt
- newbin dgraph/dgraph.${ext} ${PN}-dgraph
- newbin editor/editor.${ext} ${PN}-editor
- newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
- fi
-
- dodoc README.adoc CREDITS FAQ CHANGES
- if use doc; then
- dohtml doc/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}