summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild')
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
index 9589db20dd0f..913b9be0fc9c 100644
--- a/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.0.ebuild
@@ -3,13 +3,15 @@
EAPI=5
+inherit eutils
+
DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
HOMEPAGE="https://github.com/ocaml/ocamlbuild"
SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="+ocamlopt test"
RESTRICT="!test? ( test )"
@@ -20,6 +22,10 @@ RDEPEND="${DEPEND}
DEPEND="${DEPEND}
test? ( dev-ml/findlib )"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
+}
+
src_configure() {
emake -f configure.make Makefile.config \
PREFIX="${EPREFIX}/usr" \