summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml_intrinsics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 11:30:05 +0100
commit8164a4e49d69b936f2d820456e48468dc0e241ad (patch)
tree72c381896b721d4947b8f65f0cadceef779b99ae /dev-ml/ocaml_intrinsics
parentc3ec60d8953748433a04137e04480e9c1a36ed4c (diff)
gentoo auto-resync : 02:07:2023 - 11:30:05
Diffstat (limited to 'dev-ml/ocaml_intrinsics')
-rw-r--r--dev-ml/ocaml_intrinsics/Manifest2
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/Manifest b/dev-ml/ocaml_intrinsics/Manifest
index 4f1897e12fca..6b1c26c1287a 100644
--- a/dev-ml/ocaml_intrinsics/Manifest
+++ b/dev-ml/ocaml_intrinsics/Manifest
@@ -1,5 +1,7 @@
DIST ocaml_intrinsics-0.15.1.tar.gz 24925 BLAKE2B 15d74ee891aced288aa734ef4d70a4816f2d2725d0d445620154bec7d1667d3ac06c5ddd778777d15858cbf198ecd978b22959fe68e159ddd9dbbd32304c3077 SHA512 cb0ac26bc34c97eb0429e6833342dbd9fca6f1f4a40b8121f9e6364bd2cdc40676a164d7405454727ced9a4455adb0e3cac5118beb7ab70206adbd3e7f7937e2
DIST ocaml_intrinsics-0.15.2.tar.gz 24977 BLAKE2B eea2af5ff746cfd7b483df47a8f719c623eecc8bf82d852ed69395752e98ebb94a555ef2dd95271d45941a5582f7ff139f8e79d5dd8adf5389786aff756df7fe SHA512 21539fecd8b40420bdb45a3fe79f65cf4ff0deb103c3cb2b28bad24fddce159bdfab3f7aa6ade0028bebef1602f860b1f6cdf2cc06db1a89e232b221d8ff592b
+DIST ocaml_intrinsics-0.16.0.tar.gz 35876 BLAKE2B fc9ead65244efe96ea130426265acb2cccc08105e53383ddfd7117bca461e28095f213f22dddafc1e3f6490ad2b4f0d4e9129a8dcf8dc207269ca83eb889acee SHA512 86bf6ac7cb1da5de03224cc053e174ec22af766b6c5ab4ca1fde3c028405858cb97feeae6968d9054a7d6994491b9f2cdb8e198ee837ad4242f9cd812873ceaa
EBUILD ocaml_intrinsics-0.15.1.ebuild 515 BLAKE2B 3d7d3bd127410d1f55bfa9f1e48a24cf6d9961c320bf6d0376207944035568f2648484b3df6faad4d0293f8139fda912991072b819ef4b7ebc1d0d0ac6d08df4 SHA512 015d46740fe8433b24da39935cb1301c28c89a97c3d6995f4dd193a774a12520211e2329e4b14e96f07bbe129c2260660dc2aa5b7da05900377a457215d22965
EBUILD ocaml_intrinsics-0.15.2.ebuild 544 BLAKE2B 07dabc481cfc9fd3b367b7763d0fbb2a5d990d30cd9c89adf5bfa208de9f599ef516fcd5d582627dfbc2cde2a49f5e3ff35b843553441ca39dc08cee7a539f0a SHA512 7562bdd9f302706d466f143e7ec2847cb35c8694bad1f4488204e61d3fee4c368d2de17300fa8e35439bad13f35bbc0090d38c58a0a14b009920555eeacf5d33
+EBUILD ocaml_intrinsics-0.16.0.ebuild 548 BLAKE2B c2bf2d585a1352752510c62c760ac9e930f180c1a45df2e9569ade3f85515498faae74d80e2f0596396618e08588207648a0c7c7be453a10be32d6febb2f4e94 SHA512 2d636b7e20b53c4fa9e94770fdc6ed62d98fe7f9392acb12a87dcbc345b58f55a713139025f00dbf10eb851c366acbb71cb13b57abcdef2ac0bf4c6dc65bd6db
MISC metadata.xml 326 BLAKE2B 737c6608b5b4282d53fb3e866199fbb672076c968f849b0f5b9a5da732c6db556b7b5f597e5d90e53a2a607cf02e7cbc01a5453e6e483721b47e2451cbe1285d SHA512 be860a17f734273b190dca122353092b24fbd0c37dfcf4121c28171227a412b29c92d063a21e6d767f4679bb3d92ac800fb621fec82f8d2fc45856252c19f5db
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild
new file mode 100644
index 000000000000..7e383a4f2da6
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"