summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml_intrinsics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ml/ocaml_intrinsics
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ml/ocaml_intrinsics')
-rw-r--r--dev-ml/ocaml_intrinsics/Manifest2
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/Manifest b/dev-ml/ocaml_intrinsics/Manifest
index 4e179fe352e5..58ee39c7eff1 100644
--- a/dev-ml/ocaml_intrinsics/Manifest
+++ b/dev-ml/ocaml_intrinsics/Manifest
@@ -1,3 +1,5 @@
DIST ocaml_intrinsics-0.15.1.tar.gz 24925 BLAKE2B 15d74ee891aced288aa734ef4d70a4816f2d2725d0d445620154bec7d1667d3ac06c5ddd778777d15858cbf198ecd978b22959fe68e159ddd9dbbd32304c3077 SHA512 cb0ac26bc34c97eb0429e6833342dbd9fca6f1f4a40b8121f9e6364bd2cdc40676a164d7405454727ced9a4455adb0e3cac5118beb7ab70206adbd3e7f7937e2
+DIST ocaml_intrinsics-0.15.2.tar.gz 24977 BLAKE2B eea2af5ff746cfd7b483df47a8f719c623eecc8bf82d852ed69395752e98ebb94a555ef2dd95271d45941a5582f7ff139f8e79d5dd8adf5389786aff756df7fe SHA512 21539fecd8b40420bdb45a3fe79f65cf4ff0deb103c3cb2b28bad24fddce159bdfab3f7aa6ade0028bebef1602f860b1f6cdf2cc06db1a89e232b221d8ff592b
EBUILD ocaml_intrinsics-0.15.1.ebuild 515 BLAKE2B 3d7d3bd127410d1f55bfa9f1e48a24cf6d9961c320bf6d0376207944035568f2648484b3df6faad4d0293f8139fda912991072b819ef4b7ebc1d0d0ac6d08df4 SHA512 015d46740fe8433b24da39935cb1301c28c89a97c3d6995f4dd193a774a12520211e2329e4b14e96f07bbe129c2260660dc2aa5b7da05900377a457215d22965
+EBUILD ocaml_intrinsics-0.15.2.ebuild 519 BLAKE2B e9718a993fcc4bb3e839dc4670897c59602f8b54bdc272a1d49560735e6429f435dad198fcc0f4f124a851f86ff25454b6e74adf728fe7286e84bd3a1b97d83c SHA512 ebeb577c7fed092c6ebc2c19917627cefa872d7f4e398904fb9b3d4c7d76986ebc3063f09b147bb2e33487756e37d179c283b4d13a2c2f181de98cbbf58ddd6c
MISC metadata.xml 326 BLAKE2B 737c6608b5b4282d53fb3e866199fbb672076c968f849b0f5b9a5da732c6db556b7b5f597e5d90e53a2a607cf02e7cbc01a5453e6e483721b47e2451cbe1285d SHA512 be860a17f734273b190dca122353092b24fbd0c37dfcf4121c28171227a412b29c92d063a21e6d767f4679bb3d92ac800fb621fec82f8d2fc45856252c19f5db
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
new file mode 100644
index 000000000000..febba2e21179
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"