summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild')
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
new file mode 100644
index 000000000000..febba2e21179
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"