summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-text/ocaml-text-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-text/ocaml-text-0.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-text/ocaml-text-0.8.ebuild')
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/ocaml-text-0.8.ebuild b/dev-ml/ocaml-text/ocaml-text-0.8.ebuild
new file mode 100644
index 000000000000..ebcdda2a93f6
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Library for dealing with 'text'"
+HOMEPAGE="https://github.com/vbmithr/ocaml-text/"
+SRC_URI="https://github.com/vbmithr/ocaml-text/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+RDEPEND="virtual/libiconv
+ dev-ml/camlp4:=
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/rubber virtual/latex-base )"
+
+DOCS=( "README" "CHANGES" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}
+
+src_install() {
+ oasis_src_install
+ use doc && dodoc manual/*.pdf
+}