summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-redis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-redis
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-redis')
-rw-r--r--dev-ml/ocaml-redis/Manifest4
-rw-r--r--dev-ml/ocaml-redis/metadata.xml11
-rw-r--r--dev-ml/ocaml-redis/ocaml-redis-0.3.5.ebuild43
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis/Manifest b/dev-ml/ocaml-redis/Manifest
new file mode 100644
index 000000000000..09b65d5a2c7b
--- /dev/null
+++ b/dev-ml/ocaml-redis/Manifest
@@ -0,0 +1,4 @@
+DIST ocaml-redis-0.3.5.tar.gz 31217 SHA256 f43af830ab9d66619a685fbad471b97bdb5d40a4f2bdf923b76f25d139007d78 SHA512 dfd2779635fddc73ab76cd66943267c3de984edeb471728f8d6d9506cd37e9cf4b1875519c7547b90de80fd876abc7fbe6a4c9c0674fcb6a00bbe91afa6c625d WHIRLPOOL 68b02061b04a247d09fcc91fe4215ffe2bad7d8c3598c62df347da67fd698985a7a97edd3f48bcf9223b1db09cc4984c67910868a793df8cba114362f63044ad
+EBUILD ocaml-redis-0.3.5.ebuild 890 SHA256 70d4decb198f3b94da258fb426a1c8e23ea176ace373da3ddecc91aaef5bd0c6 SHA512 6f66cf7a0fb611cdeaa3fb5fde046feb43139d686aa5e2d73b645063ca9a4055b2cf349229975d3a8f0794700d18e0b76429e98d0002d17be4beb4d9fdd18658 WHIRLPOOL 3538fa9970faf1f9def2f280e9f5105f32c81c93b3440fa8a78c560466d4b3f9d65117539b96dad2a90626d0e3f80592739bda19d4fc1e6b8759d11847d53e6b
+MISC ChangeLog 1374 SHA256 1e4b46da6f68f4b214704e0044969168b5d9ddf0bf619e44098448e52bd1d7b3 SHA512 f3d7ecd2ede385e5f4bf5d09c1330657731ea8d062e302377ddccb98f637f2f52f864e7e63890317c744c81e52ced26d2d67eb9a315be80c78364ce98f170497 WHIRLPOOL 4fba49a085d8190037b484321a7d5fee6f0286601dd87f4c4e1f2241eab8069306c6d67fceb151300f26d380a7d4ea45105149913f8d963f08528eea2b922dda
+MISC metadata.xml 330 SHA256 49455bb389b79c5927c3f482faa05e1bcf9e72342eff7066ea2b9576fbfa0a8e SHA512 1194d161c4b83600e6035335c45fa912a6745700e16d36f336cf7e79d33b413b145ff7ae4b561d7e13ff35cae38004102d9bcfdbf0ae37ef24da16135c75d9d8 WHIRLPOOL 267e6344bc645ac541746446bdf4599b4b05124c79618b8cb45e53ad293329ce99ad42efe1ec15563fefd22df4923886c294df9e141f8f0ff8ce6eb18107a640
diff --git a/dev-ml/ocaml-redis/metadata.xml b/dev-ml/ocaml-redis/metadata.xml
new file mode 100644
index 000000000000..20d1ed52023f
--- /dev/null
+++ b/dev-ml/ocaml-redis/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">0xffea/ocaml-redis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-redis/ocaml-redis-0.3.5.ebuild b/dev-ml/ocaml-redis/ocaml-redis-0.3.5.ebuild
new file mode 100644
index 000000000000..97c63e8a8de4
--- /dev/null
+++ b/dev-ml/ocaml-redis/ocaml-redis-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="Redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/ https://github.com/0xffea/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-re:=
+ dev-ml/uuidm:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ test? ( dev-ml/ounit dev-db/redis dev-ml/lwt )"
+
+src_compile() {
+ jbuilder build -p redis || die
+}
+
+src_test() {
+ einfo "Starting test redis server"
+ local port=4567
+ /usr/sbin/redis-server --port ${port} &
+ local rpid=$!
+ export OCAML_REDIS_TEST_PORT=${port}
+ sleep 1
+ jbuilder runtest || { kill ${rpid}; die; }
+ kill ${rpid} || die
+}
+
+src_install() {
+ opam_src_install redis
+}