summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-redis-sync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-redis-sync
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-redis-sync')
-rw-r--r--dev-ml/ocaml-redis-sync/Manifest3
-rw-r--r--dev-ml/ocaml-redis-sync/metadata.xml11
-rw-r--r--dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis-sync/Manifest b/dev-ml/ocaml-redis-sync/Manifest
new file mode 100644
index 000000000000..b3820dc46ef5
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-redis-0.3.5.tar.gz 31217 BLAKE2B 25b83a77526e430dc3df02e3646f838240b7e43de4990f04d699f813e5ecc5a5f5bb66e643759cf9f3dd4d3a041eebeeac74d72f1fe1e4fd61b78b5ddb7160bc SHA512 dfd2779635fddc73ab76cd66943267c3de984edeb471728f8d6d9506cd37e9cf4b1875519c7547b90de80fd876abc7fbe6a4c9c0674fcb6a00bbe91afa6c625d
+EBUILD ocaml-redis-sync-0.3.5.ebuild 855 BLAKE2B 00c6c76fdc5210e07159f63bb926da874c1a7fc79210672c99553861203e7c7b72a0a2a9d73240fab312600abefbf075adac0848b018fef78deeee66aec63429 SHA512 5c46b2d0fb8dd72022809d1c3885fedaa956d708d75782da9d7fcb3fc7522529c9ec5cd21ddb751e95d676f9386f57d57bd4742e51c1cb8693e83c5c335d5dd8
+MISC metadata.xml 330 BLAKE2B 27699d6a017169526bb65a4bc31af2a74c17d8e2bc1743e2dd6583c7f4554ae1297cbe3d651fb3d3e1d74908b43aad82fe5c7118f6f4f0666f468ba91daba85c SHA512 1194d161c4b83600e6035335c45fa912a6745700e16d36f336cf7e79d33b413b145ff7ae4b561d7e13ff35cae38004102d9bcfdbf0ae37ef24da16135c75d9d8
diff --git a/dev-ml/ocaml-redis-sync/metadata.xml b/dev-ml/ocaml-redis-sync/metadata.xml
new file mode 100644
index 000000000000..20d1ed52023f
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">0xffea/ocaml-redis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild b/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild
new file mode 100644
index 000000000000..54105358e9cd
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Synchronous redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/ https://github.com/0xffea/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ocaml-redis-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-redis:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+S=${WORKDIR}/ocaml-redis-${PV}
+
+src_compile() {
+ jbuilder build -p redis-sync || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ redis-sync.install || die
+}