summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-redis-sync
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-redis-sync
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-redis-sync')
-rw-r--r--dev-ml/ocaml-redis-sync/Manifest3
-rw-r--r--dev-ml/ocaml-redis-sync/metadata.xml11
-rw-r--r--dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild42
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis-sync/Manifest b/dev-ml/ocaml-redis-sync/Manifest
new file mode 100644
index 000000000000..98112bdd7982
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-redis-0.3.5.tar.gz 31217 SHA256 f43af830ab9d66619a685fbad471b97bdb5d40a4f2bdf923b76f25d139007d78 SHA512 dfd2779635fddc73ab76cd66943267c3de984edeb471728f8d6d9506cd37e9cf4b1875519c7547b90de80fd876abc7fbe6a4c9c0674fcb6a00bbe91afa6c625d WHIRLPOOL 68b02061b04a247d09fcc91fe4215ffe2bad7d8c3598c62df347da67fd698985a7a97edd3f48bcf9223b1db09cc4984c67910868a793df8cba114362f63044ad
+EBUILD ocaml-redis-sync-0.3.5.ebuild 855 SHA256 7cd6d9f50f7c75ba483c1878dd0afa448d63abf9150b42c48ec018e469ae5878 SHA512 5c46b2d0fb8dd72022809d1c3885fedaa956d708d75782da9d7fcb3fc7522529c9ec5cd21ddb751e95d676f9386f57d57bd4742e51c1cb8693e83c5c335d5dd8 WHIRLPOOL 2433521c3c8600766d7f29ce8f46a2c7b24837c98176a5c77dc6dc4da34107e3a2afee6cd9d1b2b8fbec14b1c96761d86709ded8c256f6f1bcee3835b2f77233
+MISC metadata.xml 330 SHA256 49455bb389b79c5927c3f482faa05e1bcf9e72342eff7066ea2b9576fbfa0a8e SHA512 1194d161c4b83600e6035335c45fa912a6745700e16d36f336cf7e79d33b413b145ff7ae4b561d7e13ff35cae38004102d9bcfdbf0ae37ef24da16135c75d9d8 WHIRLPOOL 267e6344bc645ac541746446bdf4599b4b05124c79618b8cb45e53ad293329ce99ad42efe1ec15563fefd22df4923886c294df9e141f8f0ff8ce6eb18107a640
diff --git a/dev-ml/ocaml-redis-sync/metadata.xml b/dev-ml/ocaml-redis-sync/metadata.xml
new file mode 100644
index 000000000000..20d1ed52023f
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">0xffea/ocaml-redis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild b/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild
new file mode 100644
index 000000000000..54105358e9cd
--- /dev/null
+++ b/dev-ml/ocaml-redis-sync/ocaml-redis-sync-0.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Synchronous redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/ https://github.com/0xffea/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ocaml-redis-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-redis:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+S=${WORKDIR}/ocaml-redis-${PV}
+
+src_compile() {
+ jbuilder build -p redis-sync || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ redis-sync.install || die
+}