summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild')
-rw-r--r--dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild b/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
new file mode 100644
index 000000000000..a5e2d5969dd5
--- /dev/null
+++ b/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Redis bindings for OCaml via Lwt"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/ https://github.com/0xffea/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ocaml-redis-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-redis:=
+ dev-ml/lwt:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+S=${WORKDIR}/ocaml-redis-${PV}
+
+src_compile() {
+ jbuilder build -p redis-lwt || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ redis-lwt.install || die
+}