summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 00:14:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 00:14:55 +0000
commite3a48e635527f3e2d2254e9631f7a5758df9c3fb (patch)
tree7efda32bb4a58c3099db3e763ccaf7cc08e75a50 /dev-ml/ocaml-process
parent7a027cd18c60d9abad83a60c98ccf27db26be067 (diff)
gentoo auto-resync : 08:01:2023 - 00:14:55
Diffstat (limited to 'dev-ml/ocaml-process')
-rw-r--r--dev-ml/ocaml-process/Manifest2
-rw-r--r--dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild (renamed from dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild)16
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-ml/ocaml-process/Manifest b/dev-ml/ocaml-process/Manifest
index cfccd7e24842..f545fc63bf07 100644
--- a/dev-ml/ocaml-process/Manifest
+++ b/dev-ml/ocaml-process/Manifest
@@ -1,3 +1,3 @@
DIST ocaml-process-0.2.1.tar.gz 5904 BLAKE2B 90a03e53e79adae559bbdcf4717db53d5e79cf22a22e7d6daad4c123a8b275f7b984ed40b7132653c31bb9b1d7c39c1918e0455597f70103ddb18b89ecf00d9a SHA512 0ca352a273797218e1785e1f6ed024448461cefeb54f143574230c844747a81355b97dd19fe9ddfe31d1a69c03dccf895fadc086f61a3d7a9f5397538432db92
-EBUILD ocaml-process-0.2.1.ebuild 765 BLAKE2B cdbf6c79a839146bd47932f073651b7db0a71ac901b6cde89b1f8826afcde55a8e1fa05644fe44fd0424a54d42988f2df625dfc8d4c7fd9bea4e93d5b9f73b1f SHA512 baf187e9aa49af84b51cc1446e3446ac2dd956cdf1df1544eadeb2fc17e0f6e2e6edb10fb55f06454014625ad3b79cc4885a9bc90c801b1c3d4fee336bc5ae8d
+EBUILD ocaml-process-0.2.1-r1.ebuild 769 BLAKE2B c3aa2bdc89a53c035d63702899df2bc9f43d5241257a47e26e9dcadbf16960601229e2b314e5fd49cfc806016e2021f54327ac72915a4752cdeaca276dec0b5d SHA512 8f3e00b1c0423255d54357567008b577a0108b31a55e641c8d4f7c04064073b8edfe289319754f4a6db3c106d8ed64d21e557c2703ff69977e15cb0fdff1345d
MISC metadata.xml 402 BLAKE2B 2da7c61defac0c0ead787895a9196ad01b05166b9b0478400054213c4573dcfbc8d5b2215c761aa61f551ada92c93c967e52a39d279de12cde752fdd511fd3e8 SHA512 7796ce0714691b64e030953e53acf2dac8cbe8de6c28d4c025964017c1a2466a5637004cd60d0cc0f92d4c61d0409ea66a1944c4fe288df13cb32e9881072023
diff --git a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild b/dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild
index 2979a23b9a6f..591c51a1167c 100644
--- a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
+++ b/dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit findlib
@@ -27,12 +27,12 @@ src_compile() {
emake TARGETS="${exts}"
}
-src_install() {
- local archive=''
- use ocamlopt && archive='_build/lib/process.a'
- findlib_src_install TARGETS="${exts}" ARCHIVES=${archives}
-}
-
src_test() {
emake -j1 TARGETS=${exts} test
}
+
+src_install() {
+ local archives=''
+ use ocamlopt && archives='_build/lib/process.a'
+ findlib_src_install TARGETS="${exts}" ARCHIVES="${archives}"
+}