summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-mysql
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-mysql
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/Manifest5
-rw-r--r--dev-ml/ocaml-mysql/metadata.xml8
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild38
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild38
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/Manifest b/dev-ml/ocaml-mysql/Manifest
new file mode 100644
index 000000000000..2a699eff82a2
--- /dev/null
+++ b/dev-ml/ocaml-mysql/Manifest
@@ -0,0 +1,5 @@
+DIST ocaml-mysql-1.2.1.tar.gz 99250 BLAKE2B 576eb7cc7ccf9e747f207faa100adb7f10a17be2083dbd4f1fb352f8a023425eb7917d7bd4756ddafd663657375324207596e97d959f69c704fb1f5126b7d63d SHA512 bf9b4a1bfcc1a8d356a2d74ea9d8de8dd201973b9dc89c06349e814c2368871f5f6ccc2eca25b33fa5fabf4b6d19a5b4b436a1e055b90468f16f575257121e64
+DIST ocaml-mysql-1.2.2.tar.gz 99136 BLAKE2B dcc18b51514d7a9bd7bfdf97c3f410aa959cf1b2285bd6d347cd1ebdd51952f687222b16c250d8553f7b2235bff7201978bc8debe22996566412925373c3d9d7 SHA512 2af13de017b73a31c23e0536fd10679eaf5c0692741d19729b08ab58f4d2585f8f7faf0cfac1e3ccc3d3ceffcbd1740f62621ba678c50f545fc3a3a36a17742f
+EBUILD ocaml-mysql-1.2.1.ebuild 670 BLAKE2B 29f9378548b7e97f2f3195458dc2d6513c55b98e5d5f4c000ef4cabcb6d332a3673abed39cd550a9bfe0b5f449fad891b64413ebcc694ed8e9ad59830f976d00 SHA512 fdb0a2a4e5aba6379382541a7bcbbec6266945720b64f2b698eb62e566ba8461de2cc4d8a247629dd7256e7f97a6f1ce2846c8607923aaebed3fecbb1d41692e
+EBUILD ocaml-mysql-1.2.2.ebuild 676 BLAKE2B e45d2790293307cdce31965748534d0b820dd4e4a48828137ac92eb762082afbe54aaa2ddc7689f34433bad60501f4bdb2b1ca892407bdda0f327a149179d9b7 SHA512 51bd1d5048c591f4040ca00355b4af0c0c4382ff03254f03da0b47fe25bfd8ea189838038af65b124c7e552bbe6ed741f2cb117b8ca0348c58e15d2d33f71e10
+MISC metadata.xml 253 BLAKE2B c787c1044c3f674eb5d2d7a0e830965ad53c7a2c8cdfcd95bece6b0557e35237f62afe28464ebe4c88468cd1fd543627349fd41a0aa760fceed1a7d52386eda2 SHA512 9285e04d22e8e41631e6de00e0ba02842cf0e772cd17a1d7ba3864e50eeea50abb06077ea4f9ac920eab3d520bfe28d389b3d04d5c3529af23a68ca68b6857d4
diff --git a/dev-ml/ocaml-mysql/metadata.xml b/dev-ml/ocaml-mysql/metadata.xml
new file mode 100644
index 000000000000..ffa6c6b4395b
--- /dev/null
+++ b/dev-ml/ocaml-mysql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
new file mode 100644
index 000000000000..061aa0eae84e
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
new file mode 100644
index 000000000000..a1afca457cf1
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}