summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild')
-rw-r--r--dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
new file mode 100644
index 000000000000..17c16d0e2fa3
--- /dev/null
+++ b/dev-ml/ocaml-magic-mime/ocaml-magic-mime-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Convert file extensions to MIME types"
+HOMEPAGE="https://github.com/mirage/ocaml-magic-mime"
+SRC_URI="https://github.com/mirage/ocaml-magic-mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ magic-mime.install || die
+}