summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ipaddr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-ipaddr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-ipaddr')
-rw-r--r--dev-ml/ocaml-ipaddr/Manifest3
-rw-r--r--dev-ml/ocaml-ipaddr/metadata.xml11
-rw-r--r--dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ipaddr/Manifest b/dev-ml/ocaml-ipaddr/Manifest
new file mode 100644
index 000000000000..aa88c4448d0e
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-ipaddr-2.8.0.tar.gz 22134 BLAKE2B b6e9d49fd6ac69bd4cd4884e97490a744e863541084270f55847768c2fe312334feb00fc9404028664864cc1dffccf8cf2df004a341429e78122dc64bfe0a087 SHA512 1714ee4d6b2afa17b987844f37a9896f01d7b674770fa6804b03222dba656130f9ee0d2d1409b67e770e21f973682c7d1d5c550abb0a5d94bc0c04a1a97e8e3c
+EBUILD ocaml-ipaddr-2.8.0.ebuild 667 BLAKE2B dcaa454f6079c638e75098752d1a5ac1535ad39c2cb9fdcde09210537753c7a26df98c751cc495c46a0c0aa26ed3619fda636ef2618f0aebbd4067bc6ee4925f SHA512 a6f90573a6b2b6558883cc3e34d96af353e8e254e519705fd0a76c533a0a0815ac5a7f8f74e420e836163104f88e1fbcf4bba95325afca2fd0e703dbcfc0852e
+MISC metadata.xml 341 BLAKE2B d312ec476799bf0e386ee556291a24165504d67927f5bf34f533f7fc11bbee5dc7591e96b1a4955ef693bc126838ca420b8b1683983ffbadf27951a5814509b3 SHA512 1a8f24a3a717ee7afd59e82ae1000116df14fbd47cd46fd9fdbf69d2a68dd0cf7e5e7109c1ae1f7a757ab17ece18f042bf64bb01da53acb2d8f990c3c2399eb5
diff --git a/dev-ml/ocaml-ipaddr/metadata.xml b/dev-ml/ocaml-ipaddr/metadata.xml
new file mode 100644
index 000000000000..1d6e7b2fd2e2
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-ipaddr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
new file mode 100644
index 000000000000..c4a103f9a450
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
+HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
+SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ dev-lang/ocaml:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/findlib
+ test? ( dev-ml/ounit )
+"
+
+src_install() {
+ opam_src_install ipaddr
+}