summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-09 03:17:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-09 03:17:10 +0000
commit8b5d973bd4c43f578cef7a46652599e470f1d9fc (patch)
treecc4312079c10bc8c7f3c48d4c9dbb9d14f7c2f00 /dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
parent750f865355947c40a4b93cd7a5db23eebc4e5080 (diff)
gentoo auto-resync : 09:12:2022 - 03:17:09
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..37311d0f25e8
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=fileutils
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-${PV}.tbz -> ${P}.tar.bz2"
+S="${WORKDIR}"/${DUNE_PKG_NAME}-${PV}
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-ml/stdlib-shims:="
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"
+
+PATCHES=( "${FILESDIR}"/${P}-dune.patch )
+
+DOCS=( CHANGES.md LICENSE.txt README.md )