summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..9cf634b3f69e
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0:=
+ >=dev-ml/stdlib-shims-0.2.0:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/dune || die
+}