summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-dispatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-dispatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-dispatch')
-rw-r--r--dev-ml/ocaml-dispatch/Manifest5
-rw-r--r--dev-ml/ocaml-dispatch/metadata.xml11
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild34
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild43
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dispatch/Manifest b/dev-ml/ocaml-dispatch/Manifest
new file mode 100644
index 000000000000..9b5e66b8d1b1
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/Manifest
@@ -0,0 +1,5 @@
+DIST ocaml-dispatch-0.3.0.tar.gz 51453 BLAKE2B bd7965396a82a9f767abd05079496a5e0c1f12c3fe02d8c1d79b41db10010eefd89edf3351d8d05f132f0df3c3ab79533902a98752e571bfd09d4f2798f1db57 SHA512 0f09eae45a2ecae27d07e247b6a47f307e074342e337e7be262f5183f77090f0aef81fb5c0bf499732bd0a711d4d51775cbcea5e463011f43a1777582d78806b
+DIST ocaml-dispatch-0.4.0.tar.gz 7554 BLAKE2B 9bbe102df8a27642cbf54ad876caa276ba966ca3b19af53ac8f957799d0ca98b030c0d5ec055cc2868b2c374d71371c6e91ef0b89f4b5a072fbe2c47133df919 SHA512 d5318bda4079c21820fce5b21d178ed88fd0535a5cdc559dd6ceeb4d06ffb08456ee5aec1e56efd40b6d4f456f7d5c7eda17dc728666e6514dc936898b605b36
+EBUILD ocaml-dispatch-0.3.0.ebuild 764 BLAKE2B 646d1d85f42a526e3d40a1fd8a9f421fd40353f56fb4ef57c7b4935b346113ed13408291adbadd3e02a6514781d424f71bc3737621256d71c82069e2a3523208 SHA512 27e4714792648b99cf1ca4c317f4b25c67dba6f0b64be21e2b51f4dfce49594d5a2625e5299840dac9b3022272beef6a5e50411c18fcebea11cb27a4b7499a01
+EBUILD ocaml-dispatch-0.4.0.ebuild 854 BLAKE2B 8552541c0c85cbe64fae5fde8bd95174b1cc79cf70bc59b6b370aa6eda255d5ab8ed6aa316e1b99622a6fb9d1d3760d9439b49e7748ab2c719b10a6810e9b1c0 SHA512 08e4d8469acadd2ba28d382ccf6b896fc40fb93b2b8714e1d4d26b3697bfe9c2ec84929328c3b5163ae5a42b54123f299657ecce8f9b191ffe24add142145909
+MISC metadata.xml 340 BLAKE2B cdcf194ca8d81e634432ffda134a91d805afdc8b36404bfdd04fae410d7240611b87a16d41e94215a290a9a01d53cc64ed9ce7931e8cf7f913ed6fb051e4907f SHA512 5e4269d0759bc87bd0addce4092da3ce6832b4cbb49eb78780d2a3a2fb00ac1bedefe29ca35c3e8525a0c9c7d49dc64c3568c3b2e9c1f7517fedfbca14a099d4
diff --git a/dev-ml/ocaml-dispatch/metadata.xml b/dev-ml/ocaml-dispatch/metadata.xml
new file mode 100644
index 000000000000..44eccfc3febe
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">inhabitedtype/ocaml-dispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
new file mode 100644
index 000000000000..0056e666f79f
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript"
+
+DEPEND="
+ javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
+ dev-ml/result:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
new file mode 100644
index 000000000000..562ef548b9a1
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-ml/result:=
+ dev-lang/ocaml:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ jbuilder build -p dispatch || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall dispatch
+}