summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
new file mode 100644
index 000000000000..f2c3d64f44a8
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit dev-ml/lwt )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}