summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-cstruct
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-cstruct')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest4
-rw-r--r--dev-ml/ocaml-cstruct/metadata.xml16
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild64
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
new file mode 100644
index 000000000000..14dba61877e9
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -0,0 +1,4 @@
+DIST ocaml-cstruct-3.1.1.tar.gz 208725 SHA256 0b4469b17daaf7e6423962f2ad3ea02f4d4e35a7b92acb404afa6738570be3d6 SHA512 22ec8fe027dbebee537ff950c2aa9a494d0c4c000d8c4df848eae157b1c9502b73c208bb92c21fa4c13ba0291b7750de31e4c96b3a0571397402f841c3e01c21 WHIRLPOOL 287df0058f4291e2cbeb716f9a26aa7475ddcbfce6d1373c3d7a82d9c49d6c4d167de13298525f94414a9bcff2abff5e6d909a5de25d5063711a5a70f504d2ea
+EBUILD ocaml-cstruct-3.1.1.ebuild 1286 SHA256 9324a59519f561105c4387999b1ef0070af3aa53b9c38c76eb7ff1801b9317e3 SHA512 f0952f9fac13cceccf9c02620da596c61e134f9580110f009b821feea85c03ecdce3649fed7b4b87408a6df1b3f973f53e4738b148cc14118383cb3fa0e381d7 WHIRLPOOL d0d7052f7ec9fae9f5d6d91c393eb5b059bc56629382ef6cb0c3b6ecb15202dfa46208436c35102068e43fe06e5399518c6469ba7e90cb0ffef7c5931e977f1a
+MISC ChangeLog 5015 SHA256 6fc46b30e7647bd6fb9c85f82bd4bff1f4078360b174907eac46e8396d928226 SHA512 33353005e2b16a8db99d65f99d2156f54592e77a248efda07aa08281dc240c016fe7816c7323009713725954878cad2eb73fe8ec608a1b2b4ac9d23193b49bdd WHIRLPOOL 49f29f7d88be56fc885cffa6f150016af7ca1842e7b43d0c1479478b8610f9917007e952d636c52f1f1c0c3a44781fa3986f65aa0d7427d596faa62dca9361e4
+MISC metadata.xml 569 SHA256 be32ad231b4437ca296ff14a5f7ed0c3d888507ff81997f3e1c8ca36b3dc0908 SHA512 842931d7b44d9425ee70782b1e7931bb6ee89f0e0d4da55dab36917ecd6f49b237d9e0d5681659e2db91ab4ff6d3c9d0faf4574bf9f4a7cc3c2574248513ad7f WHIRLPOOL 681a231ad2fec9544173e22ae3cf1874bb05854714eba03ddc56c00163b811fc806141d8e7c758e4ba56b5923f878e71c672718a06ea63b1aeb4e58692f1144b
diff --git a/dev-ml/ocaml-cstruct/metadata.xml b/dev-ml/ocaml-cstruct/metadata.xml
new file mode 100644
index 000000000000..3770faddf424
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="async">Support for asynchronous execution</flag>
+ <flag name="lwt">Enable threads via lwt</flag>
+ <flag name="ppx">Enable the ppx syntax extension</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-cstruct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
new file mode 100644
index 000000000000..1b42677acb65
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? (
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core_kernel:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ >=dev-ml/ppx_tools_versioned-5.0.1:=
+ )
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ test? (
+ dev-ml/ounit
+ ppx? ( dev-ml/ppx_driver dev-ml/ppx_sexp_conv )
+ )
+ ${RDEPEND}
+"
+
+get_targets() {
+ local tgt="cstruct,cstruct-unix"
+ use lwt && tgt+=",cstruct-lwt"
+ use async && tgt+=",cstruct-async"
+ use ppx && tgt+=",ppx_cstruct"
+ echo "${tgt}"
+}
+
+src_compile() {
+ jbuilder build -p $(get_targets) || die
+}
+
+src_test() {
+ jbuilder runtest -p $(get_targets) || die
+}
+
+src_install() {
+ opam-install cstruct
+ opam-install cstruct-unix
+ use lwt && opam-install cstruct-lwt
+ use async && opam-install cstruct-async
+ use ppx && opam-install ppx_cstruct
+}