summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-cstruct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-cstruct
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-cstruct')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest3
-rw-r--r--dev-ml/ocaml-cstruct/metadata.xml16
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild64
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
new file mode 100644
index 000000000000..9d4ab6ed6884
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-cstruct-3.1.1.tar.gz 208725 BLAKE2B 2818c5695c4ab3d102cfa08a288e80e80d7fa4372a5d97aac831429f0681e21cb6b03baac245c7c1171a8efa23b8d6bca661ee74db0efe8c2649727d9be56505 SHA512 22ec8fe027dbebee537ff950c2aa9a494d0c4c000d8c4df848eae157b1c9502b73c208bb92c21fa4c13ba0291b7750de31e4c96b3a0571397402f841c3e01c21
+EBUILD ocaml-cstruct-3.1.1.ebuild 1286 BLAKE2B 73783886dbe41051cf24db9149f55aaef3f625416d740752a152245dbda7c9f7d0158ebe15134bcebd84d99008e428e4b7e24640dd33382fbe8bdfd1d1aaa773 SHA512 f0952f9fac13cceccf9c02620da596c61e134f9580110f009b821feea85c03ecdce3649fed7b4b87408a6df1b3f973f53e4738b148cc14118383cb3fa0e381d7
+MISC metadata.xml 569 BLAKE2B bfe51e629d78d5ddda2f30667a2e8665d7d8f6ea21be3a308c9a3dafa75898323ecf78f3738c8b789de9f36050b020a1037f9624eec56eb54619a93bed49997b SHA512 842931d7b44d9425ee70782b1e7931bb6ee89f0e0d4da55dab36917ecd6f49b237d9e0d5681659e2db91ab4ff6d3c9d0faf4574bf9f4a7cc3c2574248513ad7f
diff --git a/dev-ml/ocaml-cstruct/metadata.xml b/dev-ml/ocaml-cstruct/metadata.xml
new file mode 100644
index 000000000000..3770faddf424
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="async">Support for asynchronous execution</flag>
+ <flag name="lwt">Enable threads via lwt</flag>
+ <flag name="ppx">Enable the ppx syntax extension</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-cstruct</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
new file mode 100644
index 000000000000..1b42677acb65
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? (
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core_kernel:=
+ )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ >=dev-ml/ppx_tools_versioned-5.0.1:=
+ )
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ test? (
+ dev-ml/ounit
+ ppx? ( dev-ml/ppx_driver dev-ml/ppx_sexp_conv )
+ )
+ ${RDEPEND}
+"
+
+get_targets() {
+ local tgt="cstruct,cstruct-unix"
+ use lwt && tgt+=",cstruct-lwt"
+ use async && tgt+=",cstruct-async"
+ use ppx && tgt+=",ppx_cstruct"
+ echo "${tgt}"
+}
+
+src_compile() {
+ jbuilder build -p $(get_targets) || die
+}
+
+src_test() {
+ jbuilder runtest -p $(get_targets) || die
+}
+
+src_install() {
+ opam-install cstruct
+ opam-install cstruct-unix
+ use lwt && opam-install cstruct-lwt
+ use async && opam-install cstruct-async
+ use ppx && opam-install ppx_cstruct
+}