summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-containers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-containers
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-containers')
-rw-r--r--dev-ml/ocaml-containers/Manifest5
-rw-r--r--dev-ml/ocaml-containers/metadata.xml11
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild32
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild32
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
new file mode 100644
index 000000000000..c928b6ecb12f
--- /dev/null
+++ b/dev-ml/ocaml-containers/Manifest
@@ -0,0 +1,5 @@
+DIST ocaml-containers-1.3.tar.gz 299928 BLAKE2B f6c0c419e0696dc5f45bb1f1db76952aef3a9d39346a59370deaabfb787b4477e7dec2a446f5ebe8c06716ed47e0befd4dde23d8f82c6d79c80962d0e257bb02 SHA512 d4402be1d11fee883bdf2b4fcc339df6ef175ac2d6532ee865c36656473c4882290e45f2efd9b90af7298fc3ffa0ce27fb83d8c7166edeafff798ceccad929e8
+DIST ocaml-containers-1.4.tar.gz 302136 BLAKE2B abb70e4141443d84680090cf1610b293203839ab1a6daa77ebd4980ae6f60a25f63fd8206693612b1104e4f289c16a313e83901297c4104cbdd02ed2917903b3 SHA512 f96c83a139cc277bb60f572966965eb3b669afe6dadd926f9baf42e8effb5f47fb4ba7628ee91ce3896a270f12e5828bc4dd9364cc6f187e800b07305fadce75
+EBUILD ocaml-containers-1.3.ebuild 681 BLAKE2B f2d88f4e3a3b25b0c5d051735cbbb116c5722d40a82118b644ef2180e2ef73a93b80d8c76e5f503cfdb8220de48fca72b2ccd3fe9c34a2c8778677a256712eaf SHA512 1050976dffe785acd9b6f562a3fe66f72b815ee78a0ac5045aa624427366b33f5586d435ea27294b89b7bc666e32de1bf889eef888556b520c9cf0a4bc514bd1
+EBUILD ocaml-containers-1.4.ebuild 681 BLAKE2B f2d88f4e3a3b25b0c5d051735cbbb116c5722d40a82118b644ef2180e2ef73a93b80d8c76e5f503cfdb8220de48fca72b2ccd3fe9c34a2c8778677a256712eaf SHA512 1050976dffe785acd9b6f562a3fe66f72b815ee78a0ac5045aa624427366b33f5586d435ea27294b89b7bc666e32de1bf889eef888556b520c9cf0a4bc514bd1
+MISC metadata.xml 335 BLAKE2B 85b3e5873d248d4120a19de4845c3c905d4640333aec2eecfca08c4cfb0eae285b226b630065d6a31b4ca011fa40eeaed76ef04bffdbf60c6473d4e79e33eb45 SHA512 9c960d71be6f05d8d34283cbe8d29f3134648b19587288ffeffad63c844c93c47f662bc181fc644c3b02a19901c6f859baacc6802db0947a002b9835867980a0
diff --git a/dev-ml/ocaml-containers/metadata.xml b/dev-ml/ocaml-containers/metadata.xml
new file mode 100644
index 000000000000..6cc1172e3347
--- /dev/null
+++ b/dev-ml/ocaml-containers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">c-cube/ocaml-containers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild
new file mode 100644
index 000000000000..33e8871a4f73
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
new file mode 100644
index 000000000000..33e8871a4f73
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}