summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-compiler-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
commit65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (patch)
tree541cbae0eb51d2fdb39d64b3d135d1a6f7994dc8 /dev-ml/ocaml-compiler-libs
parent0aad4cd3e3fe3db90904ffc51b35e4ff160b53c5 (diff)
gentoo auto-resync : 11:06:2024 - 00:08:04
Diffstat (limited to 'dev-ml/ocaml-compiler-libs')
-rw-r--r--dev-ml/ocaml-compiler-libs/Manifest2
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocaml-compiler-libs/Manifest b/dev-ml/ocaml-compiler-libs/Manifest
index abbe1b000055..989ab61fc2f4 100644
--- a/dev-ml/ocaml-compiler-libs/Manifest
+++ b/dev-ml/ocaml-compiler-libs/Manifest
@@ -1,5 +1,7 @@
DIST ocaml-compiler-libs-0.12.3.tar.gz 4982 BLAKE2B 83432cbb2707964f025b294a84cdcce77137156e409d85ce8615dd6e9a26ad085cd5de178ebeb7520cd95b19a15b3cfbf7ef9567d165b55e07850a231b68371c SHA512 748ae11fe4cedb12d153ef2e712a9899f6a7ab4a35ddb7c95c0ae25af979c3edf274046745dddb2253fc06be41d5b0029f11a5a823a17d1ee680ffb29c4bdc89
DIST ocaml-compiler-libs-0.12.4.tar.gz 5435 BLAKE2B 2c7b3f79315945d094dd4102da748dda55265bdd36753606ec03eef6a39eb385b84e7bfd0f43a04583271bf7c53b15481e9dcbb48c362d472bb3f740ec48853a SHA512 cf08e8d4bf25fff26a16a05036f08247176f4845d9d9ada85944c3fa89b6df9a5092d7a1025415a3b2ce00dd45b544cc82247648cf3952be2304e5d9ebab121d
+DIST ocaml-compiler-libs-0.17.0.tar.gz 5006 BLAKE2B c5f5f3e257167fad012135a76a82d6c2609a7ba6956f2380c8d19fc5f8360a2110b1cfcec9eecbe779c5c155d3b593791a084f588c6c105246adf30e2d1a1d63 SHA512 c5cd418b0eb74e00c3f63235754bbdb3a3328ac743d6ae885424d8c50b4edaa7068572e689cb3456d222793283927f2984a1ff840b1bc3817f810b5314faf897
EBUILD ocaml-compiler-libs-0.12.3.ebuild 467 BLAKE2B 6c9c9e8ecf70e13089e9605d8de013d808bb8c6190bf62fb441bbf0276d25617eb8658f2dd5dece471d35959fbb5aa14c031b2e0795fb9753e9ea8ee199cbff8 SHA512 46fd1fc5f2b52cf85772bb8fb1d5fcea16d81817f2cc4135b98d6a8703bb2e45af4688499c7374b263f37afe841c22c733d54d278db1be6bd3479281279962dd
EBUILD ocaml-compiler-libs-0.12.4.ebuild 474 BLAKE2B 8cce801a509ea3734320f6b84d93bd603cbdc9716ffb6e10c2ab5af6a68bcec0d01bdf84c7d263efdfee19136660b749eea9637e73aa047c7ae73678e29ec685 SHA512 2f326c32cbe53218823556a363d03e893ada3e0dc85f373884e73985299b944b69bb587e3c9938626668c2dfed7bb63a00fc4089e66b7f59a5c90d7ca6f74e3f
+EBUILD ocaml-compiler-libs-0.17.0.ebuild 533 BLAKE2B 2efeb66eebc5e65e8b65eb0af22dc308a5ad3e09f3f46b99743dff17453c44e655f8811ed6d1aeb3b38357c133db11be1e0edde07672107d7edf92429ae37a5c SHA512 c8526dd84513dc0216aea0f2f5cc22d02dae98854ef02ef0122ccf12d5422490b69aab955c12cd8bd06a4833fbde6019d6f8ae7a020c9920b7ddbbc3b9a1dc84
MISC metadata.xml 328 BLAKE2B ea0e73ca0f6a7056e334fe09e349083a6ea531df238098f312466782f5aff013810e1c7ea691bf907798160e5f7a6e3656eddac62a99f35a829166fca01985fd SHA512 fc5230a35d7511461d1a0be41527914bf8107a21e5cffa70b88d434943af824f13278af08fe0c48320f07c049b6e165e239bd90443ecd36e9abc82096884de64
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild
new file mode 100644
index 000000000000..f273051c7a1f
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Repackage the OCaml compiler libs so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ >=dev-ml/dune-3.11
+ >=dev-lang/ocaml-5.2.0
+"