summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-augeas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-augeas
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-augeas')
-rw-r--r--dev-ml/ocaml-augeas/Manifest3
-rw-r--r--dev-ml/ocaml-augeas/metadata.xml10
-rw-r--r--dev-ml/ocaml-augeas/ocaml-augeas-0.5.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-augeas/Manifest b/dev-ml/ocaml-augeas/Manifest
new file mode 100644
index 000000000000..6d4c97aac599
--- /dev/null
+++ b/dev-ml/ocaml-augeas/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-augeas-0.5.tar.gz 59908 BLAKE2B f9f51afa0aec82e95d7bd81811e93e10587f1f2c1905338c0bbe47de61d983c24c0e5ab77aff1ca319834bf2199040a482b453177fa3c774e24ab72c3a534c14 SHA512 dfbad89790c6b5ada0e1239d002cb61a56a15350b2687d0987e0c61108d905e0c03756c08db7a3121eac3966fbeed86500e6f3c3c416cea2b974d9f50b8adabf
+EBUILD ocaml-augeas-0.5.ebuild 535 BLAKE2B 5c22974a02fb59c004f2bebe621fc1cce46c7c5b4a6c55066890309c2cfb1dfcddbb32cabe93e6e0fef2f80b93a5301710969fc699aaefed94b8168f2083e1e1 SHA512 4ab435b7610e29bef7ac6bda323eb407e1fcf3dbcbb8ae36de5e84ec54b56d392a543b9ec4b84c61dac29044be20617ed5ebbce4a4116c699a4615e9698ff4cf
+MISC metadata.xml 323 BLAKE2B f31d76fa76a0c9694f797b3d2b84a5d3181c96abaaf6ed00d69da79d5d448fe34c0f376b8e90e28695767597e801bcb47e6cac45dd4787f9f27cf6c8c2a07841 SHA512 e27d87c3ca068609ddd7af63aa00cf7a158c23c2412c0ce9c3cb2d0f298407a2bd2206639db9264c8b74bfb12d555cb47ffff03922757fb48d686b991b262818
diff --git a/dev-ml/ocaml-augeas/metadata.xml b/dev-ml/ocaml-augeas/metadata.xml
new file mode 100644
index 000000000000..738d47c70f34
--- /dev/null
+++ b/dev-ml/ocaml-augeas/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>prometheanfire@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ocaml-augeas is a set of Ocaml bindings around augeas.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-augeas/ocaml-augeas-0.5.ebuild b/dev-ml/ocaml-augeas/ocaml-augeas-0.5.ebuild
new file mode 100644
index 000000000000..f0a89730569b
--- /dev/null
+++ b/dev-ml/ocaml-augeas/ocaml-augeas-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Ocaml bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+#SRC_URI="http://augeas.net/download/ocaml/${P}.tar.gz"
+SRC_URI="https://people.redhat.com/~rjones/augeas/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-admin/augeas
+ dev-ml/ocaml-autoconf
+ dev-ml/findlib
+ dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ findlib_src_install
+}