summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-augeas/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
commit533ce9c954925ca2a6bccd1f52f266e81e61a678 (patch)
treeef0ef849f69e60394f4bbbab166e6b83848f609c /dev-ml/ocaml-augeas/files
parent9a8514e070a40648dbc8e28ad6457d925542b79a (diff)
gentoo auto-resync : 26:10:2022 - 15:55:57
Diffstat (limited to 'dev-ml/ocaml-augeas/files')
-rw-r--r--dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch21
-rw-r--r--dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch28
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch
new file mode 100644
index 000000000000..931324e5046d
--- /dev/null
+++ b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch
@@ -0,0 +1,21 @@
+http://git.annexia.org/?p=ocaml-augeas.git;a=patch;h=56c0602e972f1fae336198eb9587d71f1e36daff
+
+From 56c0602e972f1fae336198eb9587d71f1e36daff Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Tue, 20 Aug 2019 15:06:57 +0100
+Subject: [PATCH] Use ocamlopt -g option.
+
+Originally from Fedora.
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -34,8 +34,8 @@ LIBS = @AUGEAS_LIBS@ @LIBXML2_LIBS@ @LIBS@
+
+ OCAMLCFLAGS = -g
+ OCAMLCPACKAGES =
+-OCAMLOPTFLAGS =
+-OCAMLOPTPACKAGES =
++OCAMLOPTFLAGS = $(OCAMLCFLAGS)
++OCAMLOPTPACKAGES = $(OCAMLCPACKAGES)
+
+ OCAMLDOCFLAGS = -html -sort
+
diff --git a/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch
new file mode 100644
index 000000000000..937f1bb9c799
--- /dev/null
+++ b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch
@@ -0,0 +1,28 @@
+http://git.annexia.org/?p=ocaml-augeas.git;a=commit;h=1cf5aef99b26a46529ca797547c0b49627fffe78
+https://bugs.gentoo.org/750209
+
+From 1cf5aef99b26a46529ca797547c0b49627fffe78 Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Sat, 7 Dec 2019 11:08:54 +0000
+Subject: [PATCH] caml_named_value returns const value pointer in OCaml 4.09+
+
+--- a/augeas-c.c
++++ b/augeas-c.c
+@@ -86,7 +86,7 @@ static const int error_map_len = sizeof error_map / sizeof error_map[0];
+ static void
+ raise_error_and_maybe_close (augeas_t t, const char *msg, bool close_handle)
+ {
+- value *exn = caml_named_value ("Augeas.Error");
++ const value *exn = caml_named_value ("Augeas.Error");
+ value args[5];
+ const int code = aug_error (t);
+ const char *aug_err_msg;
+@@ -132,7 +132,7 @@ raise_error_and_maybe_close (augeas_t t, const char *msg, bool close_handle)
+ static void
+ raise_init_error (const char *msg)
+ {
+- value *exn = caml_named_value ("Augeas.Error");
++ const value *exn = caml_named_value ("Augeas.Error");
+ value args[5];
+
+ args[0] = caml_alloc (1, 0);