summaryrefslogtreecommitdiff
path: root/dev-ml/num/num-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-ml/num/num-1.3.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-ml/num/num-1.3.ebuild')
-rw-r--r--dev-ml/num/num-1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/num/num-1.3.ebuild b/dev-ml/num/num-1.3.ebuild
new file mode 100644
index 000000000000..e8cffd40ddb3
--- /dev/null
+++ b/dev-ml/num/num-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib findlib
+
+DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
+HOMEPAGE="https://github.com/ocaml/num"
+SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.09.0
+ >=dev-ml/findlib-1.8.1"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}"
+}