summaryrefslogtreecommitdiff
path: root/dev-ml/merlin/merlin-4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-ml/merlin/merlin-4.1-r2.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-ml/merlin/merlin-4.1-r2.ebuild')
-rw-r--r--dev-ml/merlin/merlin-4.1-r2.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-ml/merlin/merlin-4.1-r2.ebuild b/dev-ml/merlin/merlin-4.1-r2.ebuild
deleted file mode 100644
index 1433cc088f65..000000000000
--- a/dev-ml/merlin/merlin-4.1-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# TODO: vim-plugin, although it's not clear how to make it work here
-inherit elisp-common dune
-
-DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
-HOMEPAGE="https://github.com/ocaml/merlin"
-SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="emacs +ocamlopt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-ml/csexp:=
- dev-ml/yojson:=
- dev-ml/menhir:=
- =dev-lang/ocaml-4.11*:=
- emacs? (
- >=app-editors/emacs-23.1:*
- app-emacs/auto-complete
- app-emacs/company-mode
- )
-"
-DEPEND="${RDEPEND}
- test? ( app-misc/jq )"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- default
-
- # Handle installation via the eclass
- rm emacs/dune || die
-
- # rm failing test
- rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
-}
-
-src_compile() {
- dune build @install
-
- if use emacs ; then
- # Build the emacs integration
- cd emacs || die
-
- # iedit isn't packaged yet
- rm merlin-iedit.el || die
-
- elisp-compile *.el
- fi
-}
-
-src_install() {
- dune_src_install
-
- if use emacs ; then
- cd "${S}/emacs" || die
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}