summaryrefslogtreecommitdiff
path: root/dev-ml/merlin-extend/merlin-extend-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/merlin-extend/merlin-extend-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/merlin-extend/merlin-extend-0.3.ebuild')
-rw-r--r--dev-ml/merlin-extend/merlin-extend-0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/merlin-extend/merlin-extend-0.3.ebuild b/dev-ml/merlin-extend/merlin-extend-0.3.ebuild
new file mode 100644
index 000000000000..66c4758edc08
--- /dev/null
+++ b/dev-ml/merlin-extend/merlin-extend-0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="SDK to extend Merlin"
+HOMEPAGE="https://github.com/let-def/merlin-extend"
+SRC_URI="https://github.com/let-def/merlin-extend/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/cppo"
+
+src_install() {
+ findlib_src_preinst
+ default
+}