summaryrefslogtreecommitdiff
path: root/dev-ml/menhir/menhir-20230608.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
commita597364520b9291d0b2a23bb007ced022e821d95 (patch)
treefbdb29d309a73a184394006e206a8d4362ccdad8 /dev-ml/menhir/menhir-20230608.ebuild
parent1def2e3dbbf3c86abad238d1118502cfe7f61f08 (diff)
gentoo auto-resync : 20:08:2023 - 15:41:38
Diffstat (limited to 'dev-ml/menhir/menhir-20230608.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20230608.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20230608.ebuild b/dev-ml/menhir/menhir-20230608.ebuild
new file mode 100644
index 000000000000..0432f636319f
--- /dev/null
+++ b/dev-ml/menhir/menhir-20230608.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="https://gitlab.inria.fr/fpottier/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+src_install() {
+ dune_src_install menhir
+ dune_src_install menhirLib
+ dune_src_install menhirSdk
+}