summaryrefslogtreecommitdiff
path: root/dev-ml/menhir/menhir-20210419-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-ml/menhir/menhir-20210419-r1.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-ml/menhir/menhir-20210419-r1.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20210419-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20210419-r1.ebuild b/dev-ml/menhir/menhir-20210419-r1.ebuild
new file mode 100644
index 000000000000..eee8ab93b315
--- /dev/null
+++ b/dev-ml/menhir/menhir-20210419-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="https://gitlab.inria.fr/fpottier/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+src_install() {
+ dune_src_install menhir
+ dune_src_install menhirLib
+ dune_src_install menhirSdk
+}