summaryrefslogtreecommitdiff
path: root/dev-ml/mccs/mccs-1.1.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-ml/mccs/mccs-1.1.14.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-ml/mccs/mccs-1.1.14.ebuild')
-rw-r--r--dev-ml/mccs/mccs-1.1.14.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/mccs/mccs-1.1.14.ebuild b/dev-ml/mccs/mccs-1.1.14.ebuild
new file mode 100644
index 000000000000..85495f2cda7f
--- /dev/null
+++ b/dev-ml/mccs/mccs-1.1.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MY_PV=$(ver_rs 2 '+')
+
+DESCRIPTION="Multi Criteria CUDF Solver"
+HOMEPAGE="http://www.i3s.unice.fr/~cpjm/misc/ https://github.com/AltGr/ocaml-mccs/issues"
+SRC_URI="https://github.com/AltGr/ocaml-mccs/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/ocaml-${PN}-$(ver_rs 2 '-')
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cudf:=
+ sci-mathematics/glpk:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/extlib:=
+ )
+"