summaryrefslogtreecommitdiff
path: root/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild')
-rw-r--r--dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild
new file mode 100644
index 000000000000..38b9f1f9cd28
--- /dev/null
+++ b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=lablgtk3
+MY_P="${MY_PN}-${PV}"
+DUNE_PKG_NAME=${MY_PN}-sourceview3
+inherit dune
+
+DESCRIPTION="OCaml bindings to GTK-3"
+HOMEPAGE="https://github.com/garrigue/lablgtk"
+SRC_URI="https://github.com/garrigue/lablgtk/releases/download/${PV}/${MY_P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="3/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ x11-libs/gtksourceview:3.0=
+ >=dev-ml/lablgtk-${PV}:3=
+ dev-ml/cairo2:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P}"