summaryrefslogtreecommitdiff
path: root/dev-ml/jst-config/jst-config-0.15.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
commitbdf6e70da7a28f45617c02a251bb6b3844202bc5 (patch)
treecf66e5dcf53b2ee6842fd3ff4d24d52aa30cfebc /dev-ml/jst-config/jst-config-0.15.1-r1.ebuild
parentd414c993cafd9e31a370c4a5aae042c710df2419 (diff)
gentoo auto-resync : 28:01:2023 - 20:52:36
Diffstat (limited to 'dev-ml/jst-config/jst-config-0.15.1-r1.ebuild')
-rw-r--r--dev-ml/jst-config/jst-config-0.15.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/jst-config/jst-config-0.15.1-r1.ebuild b/dev-ml/jst-config/jst-config-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..fbed6aa260c8
--- /dev/null
+++ b/dev-ml/jst-config/jst-config-0.15.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Compile-time configuration for Jane Street libraries"
+HOMEPAGE="https://github.com/janestreet/jst-config"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/dune-configurator:=
+ dev-ml/ppxlib:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/stdio:=
+"
+RDEPEND="${DEPEND}"