summaryrefslogtreecommitdiff
path: root/dev-ml/jsonm/jsonm-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/jsonm/jsonm-1.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/jsonm/jsonm-1.0.1.ebuild')
-rw-r--r--dev-ml/jsonm/jsonm-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/jsonm/jsonm-1.0.1.ebuild b/dev-ml/jsonm/jsonm-1.0.1.ebuild
new file mode 100644
index 000000000000..301132978611
--- /dev/null
+++ b/dev-ml/jsonm/jsonm-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming JSON codec for OCaml"
+HOMEPAGE="http://erratique.ch/software/jsonm"
+SRC_URI="http://erratique.ch/software/jsonm/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-ml/uutf-1.0.0:=
+ dev-lang/ocaml:=
+ dev-ml/uchar:="
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+DOCS=( CHANGES README )
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ newbin _build/test/jsontrip.native jsontrip
+ dodoc CHANGES.md TODO.md README.md
+}