summaryrefslogtreecommitdiff
path: root/dev-ml/extlib/extlib-1.7.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 15:36:38 +0000
commit39fcd539b9eeb7df75bccad136265b5f001d1a3c (patch)
treefcedf7eec512b29edce8c642c52f834b2e15b4f8 /dev-ml/extlib/extlib-1.7.9.ebuild
parentb982051e7c8e12c3810a0d21d30d687b406b3ae5 (diff)
gentoo auto-resync : 16:12:2022 - 15:36:37
Diffstat (limited to 'dev-ml/extlib/extlib-1.7.9.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.7.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.7.9.ebuild b/dev-ml/extlib/extlib-1.7.9.ebuild
new file mode 100644
index 000000000000..d9b3eb37d2d9
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib vcs-clean
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib/"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/ocaml-${P}
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+# See bug #704146
+BDEPEND=">=dev-ml/cppo-1.6.6"
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ egit_clean
+}
+
+src_compile() {
+ cd "${S}"/src || die
+
+ emake -j1 all
+
+ use ocamlopt && emake opt cmxs
+ use doc && emake doc
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.md
+
+ use doc && dodoc -r src/doc/
+}