summaryrefslogtreecommitdiff
path: root/dev-ml/extlib/extlib-1.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/extlib/extlib-1.7.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/extlib/extlib-1.7.2.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.7.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.7.2.ebuild b/dev-ml/extlib/extlib-1.7.2.ebuild
new file mode 100644
index 000000000000..4f53ed7d6c4a
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ cd src
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt cmxs
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.md
+
+ if use doc; then
+ dohtml src/doc/*
+ fi
+}