summaryrefslogtreecommitdiff
path: root/dev-ml/easy-format/easy-format-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/easy-format/easy-format-1.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/easy-format/easy-format-1.2.0.ebuild')
-rw-r--r--dev-ml/easy-format/easy-format-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/easy-format/easy-format-1.2.0.ebuild b/dev-ml/easy-format/easy-format-1.2.0.ebuild
new file mode 100644
index 000000000000..669c69092068
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/mjambon/easy-format"
+SRC_URI="https://github.com/mjambon/easy-format/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}