summaryrefslogtreecommitdiff
path: root/dev-ml/dyn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 01:01:31 +0000
commit5d0c0ffd63620a4db788484bd36ab92b76e7891b (patch)
treeb4204d122504a5c2d3bfdb2cc9f3a5dcf5fe07b2 /dev-ml/dyn
parent60945053af0588a6219a4a6867aace9e7b47faeb (diff)
gentoo auto-resync : 20:11:2022 - 01:01:31
Diffstat (limited to 'dev-ml/dyn')
-rw-r--r--dev-ml/dyn/Manifest3
-rw-r--r--dev-ml/dyn/dyn-3.0.3.ebuild32
-rw-r--r--dev-ml/dyn/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/dyn/Manifest b/dev-ml/dyn/Manifest
new file mode 100644
index 000000000000..bb0fe494dfb7
--- /dev/null
+++ b/dev-ml/dyn/Manifest
@@ -0,0 +1,3 @@
+DIST dune-3.0.3.tar.gz 1725788 BLAKE2B 2de93c085f642c8381642a08b18bc21ad48097f32397b3eddab9725deb267b089849b649705e1b72bb1b5b37f7531fd9e0cfb134174f0cb3a8ee2595c7dcf8ce SHA512 839e942bcf8189763d0d9b01614333bb2f036bce68c82959e51d2e9145b57067cb862b66781912391c1a0f531b8dddf2ffeafcee71c626169a437fe40feba155
+EBUILD dyn-3.0.3.ebuild 718 BLAKE2B 3bac5566705c1eb6b49eed073b387542fae5560d9e1c6fb78031baa4ddf2b532f44316a4682e9547bb079f7189c6703f38e76a25e635da17d78b489ee6b3f32d SHA512 ad99b1e5e38a95d2fae8adc50429f63ab215bdc07c306d2dfd9226bf42f8b19c038732935ceb2436a602e536c1cccc6c4863b877a835a8c6d0bdbc080909e09f
+MISC metadata.xml 308 BLAKE2B 555692890c7fe4dee18d07e140384b70278e2a4a0230916a01ab9e5306776e0ed0d979e9a3487423fa1779a166da3038dca13273811e36593bb2b821b60cdfe0 SHA512 e50e28cb6f41fda295f12af1b94aba12dda8a7091322c0e7093d19ee60615d449bc1806354043e572d70aff1284e16b644b188911adbca60a2a5c8299fcee748
diff --git a/dev-ml/dyn/dyn-3.0.3.ebuild b/dev-ml/dyn/dyn-3.0.3.ebuild
new file mode 100644
index 000000000000..ba609c7fd471
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND="~dev-ml/dune-${PV}"
+DEPEND="dev-ml/ordering:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir="/usr/share/man" \
+ || die
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}
diff --git a/dev-ml/dyn/metadata.xml b/dev-ml/dyn/metadata.xml
new file mode 100644
index 000000000000..86dc156e664c
--- /dev/null
+++ b/dev-ml/dyn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/dune</remote-id>
+ </upstream>
+</pkgmetadata>