summaryrefslogtreecommitdiff
path: root/dev-ml/dyn/dyn-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-17 03:38:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-17 03:38:00 +0000
commit49b666612bff71976bd8e3cfda8c68e793c0e3ce (patch)
treedc55f15212704db247401b3f1dfe21c39886bb5e /dev-ml/dyn/dyn-3.6.1.ebuild
parentcdda1ab7293bc67061befd2b34a4ed761e887042 (diff)
gentoo auto-resync : 17:12:2022 - 03:37:59
Diffstat (limited to 'dev-ml/dyn/dyn-3.6.1.ebuild')
-rw-r--r--dev-ml/dyn/dyn-3.6.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/dyn/dyn-3.6.1.ebuild b/dev-ml/dyn/dyn-3.6.1.ebuild
new file mode 100644
index 000000000000..2ae92252343d
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="~dev-ml/ordering-${PV}:=
+ dev-ml/pp:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}