summaryrefslogtreecommitdiff
path: root/dev-ml/dyn/dyn-3.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
commit1e9c38efad2f42ea208e40924d1e5936810ac7c0 (patch)
treedbcaa52c820c84eaba974e8a5bf4ba2b05a4bed2 /dev-ml/dyn/dyn-3.10.0.ebuild
parent1f6d51a43dbfcb87ef81da70c688d354560e846a (diff)
gentoo auto-resync : 02:08:2023 - 22:51:19
Diffstat (limited to 'dev-ml/dyn/dyn-3.10.0.ebuild')
-rw-r--r--dev-ml/dyn/dyn-3.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/dyn/dyn-3.10.0.ebuild b/dev-ml/dyn/dyn-3.10.0.ebuild
new file mode 100644
index 000000000000..a3d55d2d7132
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="~dev-ml/ordering-${PV}:=
+ dev-ml/pp:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}