summaryrefslogtreecommitdiff
path: root/dev-ml/dyn/dyn-3.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
commit65c1a6f8d7210639cbdc1565ccee4758f45dfc45 (patch)
treed7bea8e8d228e76b177eccb0ffc1f45a58a1e2f7 /dev-ml/dyn/dyn-3.0.3-r1.ebuild
parentc4f077d9f57bf57fcded75904bf512075191d2d2 (diff)
gentoo auto-resync : 20:11:2022 - 13:02:32
Diffstat (limited to 'dev-ml/dyn/dyn-3.0.3-r1.ebuild')
-rw-r--r--dev-ml/dyn/dyn-3.0.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/dyn/dyn-3.0.3-r1.ebuild b/dev-ml/dyn/dyn-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..c25478c40de7
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3"
+DEPEND="~dev-ml/ordering-${PV}:=
+ dev-ml/pp:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ --libdir="$(ocamlc -where)" \
+ --mandir="/usr/share/man" \
+ || die
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}